Company Christmas Holidays
North American Headquarters in Miami, USA: Dec 25, 2015, Jan 1st 2016
European Headquarters in Muenster, Germany: Dec 21, 2015 until Jan 03rd 2016
Limited support is available during this period.
We at PROVISIO wish you Merry Christmas and a Happy New Year!

 

Rapport bogue: SiteKiosk does not autostart

Reproduction

SiteKiosk is set to autostart. The restricted user is automatically logged in on computer restart but SiteKiosk is not started.

Description

20 0000 2020-01-30 09:41:35 +0800 [SiteKiosk] Notification: [Process Status] GDI Objects: 14; USER Objects: 78; Handles: 970; Process Memory Usage: 96.68 MB
20 0000 2020-01-30 09:56:35 +0800 [SiteKiosk] Notification: [Memory Status] Physical Memory: 3.59 GB (4.20 GB free, 46.1% used); Paging File: 4.73 GB (4.31 GB free, 52.3% used)
20 0000 2020-01-30 09:56:35 +0800 [SiteKiosk] Notification: [Process Status] GDI Objects: 14; USER Objects: 76; Handles: 965; Process Memory Usage: 96.62 MB
20 03fb 2020-01-30 10:00:01 +0800 [SiteKiosk] Monitor On
20 0000 2020-01-30 10:02:39 +0800 [Maintenance] ESC Dialog:Escape Dialog has been opened
20 0000 2020-01-30 10:02:45 +0800 [Maintenance] ESC Dialog:SiteKiosk Login as Adminstrator successful
20 0000 2020-01-30 10:02:55 +0800 [Maintenance] ESC Dialog:ESC Dialog Action SKQuit started
20 0000 2020-01-30 10:02:55 +0800 [Maintenance] ESC Dialog:Escape Dialog closed
20 1772 2020-01-30 10:02:55 +0800 [SiteRemote] shutdown
20 0000 2020-01-30 10:02:55 +0800 [SiteKioskNG] Clearing cache for 'contentPlayer/App01'
20 0000 2020-01-30 10:02:55 +0800 [SiteKioskNG] Clearing cache for 'WebApp/Standalone'
20 03ea 2020-01-30 10:02:56 +0800 [SiteKiosk] closed

Réponse: (5)

Re: SiteKiosk does not autostart 31/01/2020 16:10
Are you using the default Autostart settings? What is your OS? What do you have set as your SiteKiosk start page? What do you see on the screen after the reboot? Based on the log file you included, it looks like you had to close SiteKiosk.
Re: SiteKiosk does not autostart 01/02/2020 00:34
10:02:56 was the time of the restart. On startup we got 0 lines in the log file.

Also, watchdogProviderDll, SiteremoveDll3, nodeLog and nodeErrorLog has no new entries after restart.

However, the following processes was started:

SiteKiosk Priviledged Call Dispatcher
SiteKiosk.ContentService
SiteRemote Client Service
SiteRemote Client Session Activity Monitor

In the event viewer the following relevant events occurred:
Information SiteKiosk Content Service "Service started successfully."

SiteKiosk starts successfully if I manually start it.
Re: SiteKiosk does not autostart 03/02/2020 21:29
How are you putting SiteKiosk into Autostart mode? What is your OS? What do you have set as your SiteKiosk start page? What do you see on the screen after the reboot? Based on the log file you included, you are bringing up the SiteKiosk exit dialog. That option would not be available if SiteKiosk was not running. Based on your description, it sounds like there is an issue with the start page etc in Autostart mode.
Re: SiteKiosk does not autostart 04/02/2020 00:26
OS: Windows 10
start page: https://www.bullionstar.com/retail/display/story-wall/build/index.html

Windows starts up as normal and automatically log in as SiteKiosk Restricted User. What I see is the desktop. Each time I need to double-click on the SiteKiosk icon to start your application.

The logs about the exit dialog is because I manually started SiteKiosk and exited to restart the computer.

Question 1: How can I verify that autostart mode is correctly set? Where can I find it in regedit etc?

Question 2: How can I trigger SiteKiosk to install autostart mode again or manually enter it in regedit?
Re: SiteKiosk does not autostart 04/02/2020 19:52
Does the user account you are logged in as when you put SiteKiosk in Autostart mode have full local access/admin rights? Do you get different behavior if you right-click the Start SiteKiosk icon and select Run as Administrator? In the past users have seen their antivirus blocking SitekIosk from running automatically at startup and have resolved that by adding an exception to their antivirus policies.

What is the value data for the registry entry at HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PROVISIO\SiteKiosk -> RunMode?