Company Christmas Holidays
North American Headquarters in Miami, USA: Dec 25, 2015, Jan 1st 2016
European Headquarters in Muenster, Germany: Dec 21, 2015 until Jan 03rd 2016
Limited support is available during this period.
We at PROVISIO wish you Merry Christmas and a Happy New Year!

 

Support Request: Unable to publish after licensing and SSID change

Description

I have a single android display (ViewSonic CDM4900R). I used a 30-day trial of SiteKiosk Android and the SiteRemote tools to ensure everything would work fine. Knowing that the platform would be successful, I purchased a license for SiteKiosk, as well as a 1-year subscription to SiteRemote/SiteCaster. I moved the display into the production location and entered the license keys. The WiFi network required change due to the new location, which was difficult, but successful.

The display has been online for almost 24 hours now, as shown in the SiteRemote monitoring tool, and I can push configuration to it as well as other operational commands such as restarting SiteKiosk. All entries show up successfully in log files.

However, SiteCaster continually shows that the display is offline, and I am unable to publish my signage to it. After licensing, the previously-published content was removed and it went back to the factory default display.

I have tried unregistering the display and re-registering it, renaming it in SiteRemote. Making changes and re-publishing in SiteCaster, but all to no avail. The Monitoring tool continues to show an "online" status, while SiteCaster claims that the unit is "not connected".

Réponse: (14)

Re: Unable to publish after licensing and SSID change 29/06/2020 15:32
Hello,

Thank you for your inquiry. Generally SiteKiosk and SiteCaster are only using the network connection provided by the system. So changing the SSID and adding the license shouldn't be the cause of this behavior. Considering that you had changed the network, you should check if there are any firewall restrictions (any firewall on or between Android device and internet) that would block the communication.

The main port for Android - SiteRemote communication is 5222. You can check with Chrome browser on the Android device by using http://www.siteremote.net:5222 . If the port is open you get an XML document displayed in the browser, otherwise a page could not load.

To check if port 443 outgoing is generally allowed, you can open the SiteRemote web page https://www.sitetemote.net on the device.

To check if secure web socket via port 443 is allowed (used in SiteCaster to get the content), you can open the SiteCaster editor with using Chrome browser on the Android device.

You can try this web page where it will check the Web Socket connection in a browser on the SiteKiosk machine: https://www.websocket.org/echo.html . First press "Connect" and then "Send" to see if it works.

Best regards,
Andre.
Re: Unable to publish after licensing and SSID change 29/06/2020 17:46
Tested access through firewall as suggested, and all tests pass. Able to pull and push data via SSL on port 443, and pull the unencrypted XML from port 5222 . I ran this test using a laptop on the same network and with an IP address just one off of the Android display address. I will try to get on the Android device via VNC, as it is in a location where it is challenging to use a mouse and keyboard. However, the Android device is pulling current data from the default SiteCaster display, showing Google news, Weather, and Time. I am also able to request a screenshot successfully, and it is reporting all of it's statistics into SiteRemote, so I know it is able to pull (and push) from the internet.

_That_ is my primary confusion: why is the device showing as "online" and "no errors" in SiteRemote, yet SiteCaster is showing "not connected"?
Re: Unable to publish after licensing and SSID change 29/06/2020 17:49
Here is the XML that is retrieved:

<?xml version='1.0'?><stream:stream id='14965414518292902034' version='1.0' xml:lang='en' xmlns:stream='http://etherx.jabber.org/streams' xmlns='jabber:client'><stream:error><not-well-formed xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xml:lang='en' xmlns='urn:ietf:params:xml:ns:xmpp-streams'>syntax error</text></stream:error></stream:stream>
Re: Unable to publish after licensing and SSID change 29/06/2020 18:04
Here's a link to the most recent screenshot on the device, so that you can see it is accessing internet OK.

https://www.siteremote.net/terminal/screenshot/viewer.aspx?idx=98128&displayidx=0&date=20200628165739&width=432&height=768&orgwidth=1080&orgheight=1920&filesize=40177
Re: Unable to publish after licensing and SSID change 29/06/2020 18:19
Unable to connect using the VNC connection through SiteRemote, although the SiteKiosk machine is logging the attempts.
Log Messages
10 6000 2020-06-29 18:05:04 +0200 [SiteRemote Client] Starting VNC session.
10 6000 2020-06-29 18:05:39 +0200 [SiteRemote Client] Starting VNC session.

VNC Viewer Message box gives this output:
Connection failed - End of Stream
Possible causes:
- Another user is already listening on this ID
- Bad connection

What port does VNC listen on locally?
Pages (3): [1] 2 3 Next »